#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)(?=.{1,20}$)(\S+ ?(- )?){1,3}$"
Local $sString = "The early bird catches the worm. Two words." & @CRLF & _
"" & @CRLF & _
"But only if they got up - in time." & @CRLF & _
"" & @CRLF & _
"Here we have a supercalifragilisticexpialidocious etc. sentence." & @CRLF & _
"" & @CRLF & _
"Short words." & @CRLF & _
"" & @CRLF & _
"Try accessing the .html now, please." & @CRLF & _
"" & @CRLF & _
"Vielen Dank und viele Grüße." & @CRLF & _
"" & @CRLF & _
"Did any-one try this?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")