re = /(?<!\S)(?=.{1,20}$)(\S+ ?(- )?){1,3}$/m
str = 'The early bird catches the worm. Two words.
But only if they got up - in time.
Here we have a supercalifragilisticexpialidocious etc. sentence.
Short words.
Try accessing the .html now, please.
Vielen Dank und viele Grüße.
Did any-one try this?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end