# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)(?=.{1,20}$)(\S+ ?(- )?){1,3}$"
test_str = ("The early bird catches the worm. Two words.\n\n"
"But only if they got up - in time.\n\n"
"Here we have a supercalifragilisticexpialidocious etc. sentence.\n\n"
"Short words.\n\n"
"Try accessing the .html now, please.\n\n"
"Vielen Dank und viele Grüße.\n\n"
"Did any-one try this?")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.