using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!(.).*\1)[abcd])+$";
string input = @"abcd
abc
aaa
ab
a
abb
bcajhj
dbca
dbda
bdba
cbad
jhjha";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}