re = /^(?:(?!(.).*\1)[abcd])+$/m
str = 'abcd
abc
aaa
ab
a
abb
bcajhj
dbca
dbda
bdba
cbad
jhjha'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end