$re = '/^(?:(?!(.).*\1)[abcd])+$/m';
$str = 'abcd
abc
aaa
ab
a
abb
bcajhj
dbca
dbda
bdba
cbad
jhjha';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);