const regex = /^([abcd])((?!\1)[abcd])?((?!\1|\2)[abcd])?((?!\1|\2|\3)[abcd])?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([abcd])((?!\\1)[abcd])?((?!\\1|\\2)[abcd])?((?!\\1|\\2|\\3)[abcd])?$', 'gm')
const str = `abcd
abc
aaa
ab
a
abb
abcb
dbca
dbda
bdba
cbad`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}