$re = '/^([abcd])((?!\1)[abcd])?((?!\1|\2)[abcd])?((?!\1|\2|\3)[abcd])?$/m';
$str = 'abcd
abc
aaa
ab
a
abb
abcb
dbca
dbda
bdba
cbad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);