#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*(.).*\1)([abcd]+)$"
Local $sString = "abcd" & @CRLF & _
"abc" & @CRLF & _
"aaa" & @CRLF & _
"ab" & @CRLF & _
"a" & @CRLF & _
"abb" & @CRLF & _
"abcb" & @CRLF & _
"dbca" & @CRLF & _
"dbda" & @CRLF & _
"bdba" & @CRLF & _
"cbad"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")