import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(.).*\\1)([abcd]+)$";
final String string = "abcd\n"
+ "abc\n"
+ "aaa\n"
+ "ab\n"
+ "a\n"
+ "abb\n"
+ "abcb\n"
+ "dbca\n"
+ "dbda\n"
+ "bdba\n"
+ "cbad";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}