re = /^(?!.*(.).*\1)([abcd]+)$/m
str = 'abcd
abc
aaa
ab
a
abb
abcb
dbca
dbda
bdba
cbad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end