using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/?\w+((\s+\w+(\s*=\s*(?:"".*?""|'.*?'|[^'"">\s]+))?)+\s*|\s*)\/?>";
string input = @"a paragraph with a nested image: <img src=""/sites/default/files/simpletest/254354/image-test.png""/> a paragraph with a nested image: <img src=""/sites/default/files/simpletest/254354/image-test.png""/>a paragraph with a nested image: <img src=""/sites/default/files/simpletest/254354/image-test.png"">asdf</img> asdf
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}