use strict;
my $str = 'a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png"/> a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png"/>a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png">asdf</img> asdf
';
my $regex = qr/<\/?\w+((\s+\w+(\s*=\s*(?:".*?"|'.*?'|[^'">\s]+))?)+\s*|\s*)\/?>/p;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}