// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<\/?\w+((\s+\w+(\s*=\s*(?:".*?"|'.*?'|[^'">\s]+))?)+\s*|\s*)\/?>"#).unwrap();
let string = "a paragraph with a nested image: <img src=\"/sites/default/files/simpletest/254354/image-test.png\"/> a paragraph with a nested image: <img src=\"/sites/default/files/simpletest/254354/image-test.png\"/>a paragraph with a nested image: <img src=\"/sites/default/files/simpletest/254354/image-test.png\">asdf</img> asdf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}