$re = '/(.+\d+\/+\d{1,3}"+|[^\/])+/';
$str = 'DEV-^n^n^n^n^n[Site [Screening No.]Number]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);