re = /(.+\d+\/+\d{1,3}"+|[^\/])+/
str = 'DEV-^n^n^n^n^n[Site [Screening No.]Number]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end