# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^)(?=(?:\d{3})+$)/,/gm;t' <<< "111222333444
11222333444"