$re = '/(?!^)(?=(?:\d{3})+$)/m';
$str = '111222333444
11222333444';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;