$re = '/@if\((?P<condition>.*)\)\n*\s*(?P<content>(?s:[\s\/\<\>\w\n]*))@endif/m';
$str = '@if(\'eee\' == \'esee\')
<h2>Test</h2>
@endif
@if(\'aaa\' == \'aaa\')
<h2>Test</h2>
fdlsflkjsdflkl
@endif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);