re = /@if\((?P<condition>.*)\)\n*\s*(?P<content>(?s:[\s\/\<\>\w\n]*))@endif/m
str = '@if(\'eee\' == \'esee\')
<h2>Test</h2>
@endif
@if(\'aaa\' == \'aaa\')
<h2>Test</h2>
fdlsflkjsdflkl
@endif'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end