import re
regex = re.compile(r"@if\((?P<condition>.*)\)\n*\s*(?P<content>(?s:[\s\/\<\>\w\n]*))@endif", flags=re.MULTILINE)
test_str = ("@if('eee' == 'esee')\n"
" <h2>Test</h2>\n"
"@endif\n\n"
"@if('aaa' == 'aaa')\n"
" <h2>Test</h2>\n"
" fdlsflkjsdflkl\n"
"@endif")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")