package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)! ElectricEIRChiller (?P<Brand>\w+) (?P<Model>\w+) (?P<kW>\d+)kW\/(?P<COP>.*?)COP\/(?P<Type>\w+)\n! Manufacturer = (?P<Brand2>.*?), Model Line = (?P<Model_Line>.*?)\n! Reference Capacity = (?P<kW2>.*?) kW \((?P<tons>.*?) tons\)\n! Compressor Type = (?P<compressor_type>.*?), Condenser Type = (?P<condenser_type>.*?)\n! Refrigerant = (?P<refrigerant>.*?), Voltage & Phase = (?P<Voltage>.*?)V-(?P<phase>.*?)PH-(?P<hertz>.*?)Hz\n! Unloading Mechanism = (?P<unloading_mech>.*?)\n`)
var str = `! ElectricEIRChiller Carrier 19XR 1758kW/5.86COP/VSD
! Manufacturer = Carrier, Model Line = 19XR
! Reference Capacity = 1758 kW (500 tons)
! Compressor Type = Centrifugal, Condenser Type = Water
! Refrigerant = R-134a, Voltage & Phase = 460V-3PH-60Hz
! Unloading Mechanism = VSD
!
Chiller:Electric:EIR,
ElectricEIRChiller Carrier 19XR 1758kW/5.86COP/VSD, !- Name
1758300, !- Reference Capacity {W}
5.86, !- Reference`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}