import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "! ElectricEIRChiller (?P<Brand>\\w+) (?P<Model>\\w+) (?P<kW>\\d+)kW\\/(?P<COP>.*?)COP\\/(?P<Type>\\w+)\\n! Manufacturer = (?P<Brand2>.*?), Model Line = (?P<Model_Line>.*?)\\n! Reference Capacity = (?P<kW2>.*?) kW \\((?P<tons>.*?) tons\\)\\n! Compressor Type = (?P<compressor_type>.*?), Condenser Type = (?P<condenser_type>.*?)\\n! Refrigerant = (?P<refrigerant>.*?), Voltage & Phase = (?P<Voltage>.*?)V-(?P<phase>.*?)PH-(?P<hertz>.*?)Hz\\n! Unloading Mechanism = (?P<unloading_mech>.*?)\\n";
final String string = "! ElectricEIRChiller Carrier 19XR 1758kW/5.86COP/VSD\n"
+ "! Manufacturer = Carrier, Model Line = 19XR\n"
+ "! Reference Capacity = 1758 kW (500 tons)\n"
+ "! Compressor Type = Centrifugal, Condenser Type = Water\n"
+ "! Refrigerant = R-134a, Voltage & Phase = 460V-3PH-60Hz\n"
+ "! Unloading Mechanism = VSD\n"
+ "!\n\n"
+ " Chiller:Electric:EIR,\n"
+ " ElectricEIRChiller Carrier 19XR 1758kW/5.86COP/VSD, !- Name\n"
+ " 1758300, !- Reference Capacity {W}\n"
+ " 5.86, !- Reference";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}