import re
regex = re.compile(r"! ElectricEIRChiller (?P<Brand>\w+) (?P<Model>\w+) (?P<kW>\d+)kW\/(?P<COP>.*?)COP\/(?P<Type>\w+)\n! Manufacturer = (?P<Brand2>.*?), Model Line = (?P<Model_Line>.*?)\n! Reference Capacity = (?P<kW2>.*?) kW \((?P<tons>.*?) tons\)\n! Compressor Type = (?P<compressor_type>.*?), Condenser Type = (?P<condenser_type>.*?)\n! Refrigerant = (?P<refrigerant>.*?), Voltage & Phase = (?P<Voltage>.*?)V-(?P<phase>.*?)PH-(?P<hertz>.*?)Hz\n! Unloading Mechanism = (?P<unloading_mech>.*?)\n", flags=re.MULTILINE | re.DOTALL)
test_str = ("! ElectricEIRChiller Carrier 19XR 1758kW/5.86COP/VSD\n"
"! Manufacturer = Carrier, Model Line = 19XR\n"
"! Reference Capacity = 1758 kW (500 tons)\n"
"! Compressor Type = Centrifugal, Condenser Type = Water\n"
"! Refrigerant = R-134a, Voltage & Phase = 460V-3PH-60Hz\n"
"! Unloading Mechanism = VSD\n"
"!\n\n"
" Chiller:Electric:EIR,\n"
" ElectricEIRChiller Carrier 19XR 1758kW/5.86COP/VSD, !- Name\n"
" 1758300, !- Reference Capacity {W}\n"
" 5.86, !- Reference")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")