package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Thing_\d{3}:`)
var str = `Thing_001: foo bar blah
Thing_548: foo bar blah
Thing_991: foo bar blah
Thing_008: foo bar blah
Thing_024: foo bar blah
Thing_069: foo bar blah
Thing_357: foo bar blah
Thing_999: foo bar blah
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}