import Foundation
let pattern = #"Thing_\d{3}:"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Thing_001: foo bar blah
Thing_548: foo bar blah
Thing_991: foo bar blah
Thing_008: foo bar blah
Thing_024: foo bar blah
Thing_069: foo bar blah
Thing_357: foo bar blah
Thing_999: foo bar blah
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)