$re = '/Thing_\d{3}:/';
$str = 'Thing_001: foo bar blah
Thing_548: foo bar blah
Thing_991: foo bar blah
Thing_008: foo bar blah
Thing_024: foo bar blah
Thing_069: foo bar blah
Thing_357: foo bar blah
Thing_999: foo bar blah
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);