using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'text':\s*(['""])((?:\\\1|(?!\1).)*)\1";
string input = @"[{'text': 'This is my legit ""test"" \'message\' with ""lots"" of \'quotation marks\'', 'type': 'message', 'user': '<userID>', 'channel': '<channelID>, 'ts': '1450501889.000074', 'team': '<teamID'}]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}