re = /'text':\s*(['"])((?:\\\1|(?!\1).)*)\1/m
str = '[{\'text\': \'This is my legit "test" \\\'message\\\' with "lots" of \\\'quotation marks\\\'\', \'type\': \'message\', \'user\': \'<userID>\', \'channel\': \'<channelID>, \'ts\': \'1450501889.000074\', \'team\': \'<teamID\'}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end