$re = '/\'text\':\s*([\'"])((?:\\\\\1|(?!\1).)*)\1/m';
$str = '[{\'text\': \'This is my legit "test" \\\'message\\\' with "lots" of \\\'quotation marks\\\'\', \'type\': \'message\', \'user\': \'<userID>\', \'channel\': \'<channelID>, \'ts\': \'1450501889.000074\', \'team\': \'<teamID\'}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);