const regex = /(destination=)[^$|&]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(destination=)[^$|&]+', 'g')
const str = `http://localhost/myweb/login/resend_password?destination=http://localhost%2Fmyweb%2Fsearch%3Fs%3Dislamic_sources%26q%3D%25D8%25B3%25D9%2584%25D8%25A7%25D9%2585`;
const subst = `$1newval`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);