$re = '/(destination=)[^$|&]+/';
$str = 'http://localhost/myweb/login/resend_password?destination=http://localhost%2Fmyweb%2Fsearch%3Fs%3Dislamic_sources%26q%3D%25D8%25B3%25D9%2584%25D8%25A7%25D9%2585';
$subst = "$1newval";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;