#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*)-[^-]+(\.\w+)$"
Local $sString = "set1/2019-10-17/ASR/20190416832-ASR.pdf" & @CRLF & _
"set1/2019-03-15/DEED/20190087121-DEED.pdf" & @CRLF & _
"set1/2021-06-22/DT/20210376486-DT.pdf"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)