# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*)-[^-]+(\.\w+)$"
test_str = ("set1/2019-10-17/ASR/20190416832-ASR.pdf\n"
"set1/2019-03-15/DEED/20190087121-DEED.pdf\n"
"set1/2021-06-22/DT/20210376486-DT.pdf")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.