import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*)-[^-]+(\\.\\w+)$";
final String string = "set1/2019-10-17/ASR/20190416832-ASR.pdf\n"
+ "set1/2019-03-15/DEED/20190087121-DEED.pdf\n"
+ "set1/2021-06-22/DT/20210376486-DT.pdf";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}