#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<([^> ]+)[^>]*>[^<]*<([^> ]+)[^>]*>({{.*}})<\/\2>[^<]*<\/\1>"
Local $sString = "# <td><p>{{README.README}}</p></td>" & @CRLF & _
"# My soluction is independent of the HTML tags which make it very flexible." & @CRLF & _
"# Work with javascript, python and php(probably you are using javascript)." & @CRLF & _
"#" & @CRLF & _
"# Alternative soluctions... copy and try!" & @CRLF & _
"# More expecific:" & @CRLF & _
" <([^> ]+)[^>]*>[^<]*<([^> ]+)[^>]*>({{custom.amountTable}})<\/\2>[^<]*<\/\1>" & @CRLF & _
"# More expecific and faster:" & @CRLF & _
" <(tr)[^>]*>[^<]*<(td)[^>]*>({{custom.amountTable}})<\/\2>[^<]*<\/\1>" & @CRLF & _
"<thead>" & @CRLF & _
"<tr style="background-color: #487cdb; text-align: center;">" & @CRLF & _
"<td style="width: 224px;">qwerqwerqwer</td>" & @CRLF & _
"<td style="width: 224px;">qwerqwerqwer</td>" & @CRLF & _
"<td style="width: 225px;">qwerqwerqwer</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</thead>" & @CRLF & _
"<tbody>" & @CRLF & _
"<tr>" & @CRLF & _
"<td style="width: 224px;"> </td>" & @CRLF & _
"<td style="width: 224px;"> </td>" & @CRLF & _
"<td style="width: 225px;"> </td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr style="text-align: center;">" & @CRLF & _
"<td style="width: 224px;" colspan="3">{{custom.amountTable}}</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td style="width: 224px;"> </td>" & @CRLF & _
"<td style="width: 224px;"> </td>" & @CRLF & _
"<td style="width: 225px;"> </td>" & @CRLF & _
"</tr>" & @CRLF & _
"</tbody>" & @CRLF & _
"</table>" & @CRLF & _
"" & @CRLF & _
"# <td><p>{{HEY.FYI}}</p></td>" & @CRLF & _
"# I could make a function that generate the regex dinamicly, for example you " & @CRLF & _
"# could pass the expecific {{custom.property}} part " & @CRLF & _
"# and the level of HTML tags to match" & @CRLF & _
"# matchFunction('custom.amountTable', 2))" & @CRLF & _
"" & @CRLF & _
"<tag whatever="property">" & @CRLF & _
"<anothertag>{{custom.whatever}}</anothertag>" & @CRLF & _
"</tag>" & @CRLF & _
"" & @CRLF & _
"<td><p>{{custom.whatever}}</p></td>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"#Junior Báez: https://www.linkedin.com/in/jrbaez01/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")