# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<([^> ]+)[^>]*>[^<]*<([^> ]+)[^>]*>({{.*}})<\/\2>[^<]*<\/\1>"
test_str = ("# <td><p>{{README.README}}</p></td>\n"
"# My soluction is independent of the HTML tags which make it very flexible.\n"
"# Work with javascript, python and php(probably you are using javascript).\n"
"#\n"
"# Alternative soluctions... copy and try!\n"
"# More expecific:\n"
" <([^> ]+)[^>]*>[^<]*<([^> ]+)[^>]*>({{custom.amountTable}})<\\/\\2>[^<]*<\\/\\1>\n"
"# More expecific and faster:\n"
" <(tr)[^>]*>[^<]*<(td)[^>]*>({{custom.amountTable}})<\\/\\2>[^<]*<\\/\\1>\n"
"<thead>\n"
"<tr style=\"background-color: #487cdb; text-align: center;\">\n"
"<td style=\"width: 224px;\">qwerqwerqwer</td>\n"
"<td style=\"width: 224px;\">qwerqwerqwer</td>\n"
"<td style=\"width: 225px;\">qwerqwerqwer</td>\n"
"</tr>\n"
"</thead>\n"
"<tbody>\n"
"<tr>\n"
"<td style=\"width: 224px;\"> </td>\n"
"<td style=\"width: 224px;\"> </td>\n"
"<td style=\"width: 225px;\"> </td>\n"
"</tr>\n"
"<tr style=\"text-align: center;\">\n"
"<td style=\"width: 224px;\" colspan=\"3\">{{custom.amountTable}}</td>\n"
"</tr>\n"
"<tr>\n"
"<td style=\"width: 224px;\"> </td>\n"
"<td style=\"width: 224px;\"> </td>\n"
"<td style=\"width: 225px;\"> </td>\n"
"</tr>\n"
"</tbody>\n"
"</table>\n\n"
"# <td><p>{{HEY.FYI}}</p></td>\n"
"# I could make a function that generate the regex dinamicly, for example you \n"
"# could pass the expecific {{custom.property}} part \n"
"# and the level of HTML tags to match\n"
"# matchFunction('custom.amountTable', 2))\n\n"
"<tag whatever=\"property\">\n"
"<anothertag>{{custom.whatever}}</anothertag>\n"
"</tag>\n\n"
"<td><p>{{custom.whatever}}</p></td>\n\n\n"
"#Junior Báez: https://www.linkedin.com/in/jrbaez01/")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.