use strict;
my $str = '# <td><p>{{README.README}}</p></td>
# My soluction is independent of the HTML tags which make it very flexible.
# Work with javascript, python and php(probably you are using javascript).
#
# Alternative soluctions... copy and try!
# More expecific:
<([^> ]+)[^>]*>[^<]*<([^> ]+)[^>]*>({{custom.amountTable}})<\\/\\2>[^<]*<\\/\\1>
# More expecific and faster:
<(tr)[^>]*>[^<]*<(td)[^>]*>({{custom.amountTable}})<\\/\\2>[^<]*<\\/\\1>
<thead>
<tr style="background-color: #487cdb; text-align: center;">
<td style="width: 224px;">qwerqwerqwer</td>
<td style="width: 224px;">qwerqwerqwer</td>
<td style="width: 225px;">qwerqwerqwer</td>
</tr>
</thead>
<tbody>
<tr>
<td style="width: 224px;"> </td>
<td style="width: 224px;"> </td>
<td style="width: 225px;"> </td>
</tr>
<tr style="text-align: center;">
<td style="width: 224px;" colspan="3">{{custom.amountTable}}</td>
</tr>
<tr>
<td style="width: 224px;"> </td>
<td style="width: 224px;"> </td>
<td style="width: 225px;"> </td>
</tr>
</tbody>
</table>
# <td><p>{{HEY.FYI}}</p></td>
# I could make a function that generate the regex dinamicly, for example you
# could pass the expecific {{custom.property}} part
# and the level of HTML tags to match
# matchFunction(\'custom.amountTable\', 2))
<tag whatever="property">
<anothertag>{{custom.whatever}}</anothertag>
</tag>
<td><p>{{custom.whatever}}</p></td>
#Junior Báez: https://www.linkedin.com/in/jrbaez01/';
my $regex = qr/<([^> ]+)[^>]*>[^<]*<([^> ]+)[^>]*>({{.*}})<\/\2>[^<]*<\/\1>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}