package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(?P<name>[^:]+)\s*:\s*(?<amount>[\d\.,]+)\s*(?P<unit>\w+)\s*$`)
var str = `Calories: 1000 kCal
Fats: 10 gr
Saturated: 15 gr
Salt: 1 gr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}