re = /^\s*(?P<name>[^:]+)\s*:\s*(?<amount>[\d\.,]+)\s*(?P<unit>\w+)\s*$/m
str = 'Calories: 1000 kCal
Fats: 10 gr
Saturated: 15 gr
Salt: 1 gr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end