$re = '/^\s*(?P<name>[^:]+)\s*:\s*(?<amount>[\d\.,]+)\s*(?P<unit>\w+)\s*$/m';
$str = 'Calories: 1000 kCal
Fats: 10 gr
Saturated: 15 gr
Salt: 1 gr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);