const regex = /\b(?!lv)(\w+)\b (?:lv )?(?:d[iy]astolic|distolic) d[iy]sfunction/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!lv)(\\w+)\\b (?:lv )?(?:d[iy]astolic|distolic) d[iy]sfunction', 'gmi')
const str = `Mild LV diastolic dysfunction
Mild diastolic dysfunction`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}