$re = '/\b(?!lv)(\w+)\b (?:lv )?(?:d[iy]astolic|distolic) d[iy]sfunction/mi';
$str = 'Mild LV diastolic dysfunction
Mild diastolic dysfunction';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);