import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<<(.*?\\n*)*?>>";
final String string = "Organisation Name <<me.company.name>>\n"
+ "ABN/ACN <<me.company.abn>>\n"
+ "Contact Name <<me.name>>\n"
+ "<<me.PhoneNumber\n"
+ "'Another line\n"
+ ">>\n"
+ "Email <<me.emailAddress>>\n\n\n"
+ "Invoice Address \n"
+ "Notice Address (if not invoice Address) \n"
+ "<<table(“tableSites ”,me.company.sites,1)\n"
+ "’table first parameter is the bookmark that contains the table\n"
+ "‘The collection to apply to the table\n"
+ "‘and a number of rows that makes up the header (these are ignored)\n"
+ ">>\n"
+ "Connection Site Address NMI Start Date\n"
+ "<<codeobject.item.addressObject.Address>> <<codeobject.item.nmi>> <<codeobject.item.CurrentPricing.StartPeriod>>\n"
+ " \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}