import re
regex = re.compile(r"<<(.*?\n*)*?>>", flags=re.MULTILINE)
test_str = ("Organisation Name <<me.company.name>>\n"
"ABN/ACN <<me.company.abn>>\n"
"Contact Name <<me.name>>\n"
"<<me.PhoneNumber\n"
"'Another line\n"
">>\n"
"Email <<me.emailAddress>>\n\n\n"
"Invoice Address \n"
"Notice Address (if not invoice Address) \n"
"<<table(“tableSites ”,me.company.sites,1)\n"
"’table first parameter is the bookmark that contains the table\n"
"‘The collection to apply to the table\n"
"‘and a number of rows that makes up the header (these are ignored)\n"
">>\n"
"Connection Site Address NMI Start Date\n"
"<<codeobject.item.addressObject.Address>> <<codeobject.item.nmi>> <<codeobject.item.CurrentPricing.StartPeriod>>\n"
" \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")