re = /<<(.*?\n*)*?>>/m
str = 'Organisation Name <<me.company.name>>
ABN/ACN <<me.company.abn>>
Contact Name <<me.name>>
<<me.PhoneNumber
\'Another line
>>
Email <<me.emailAddress>>
Invoice Address
Notice Address (if not invoice Address)
<<table(“tableSites ”,me.company.sites,1)
’table first parameter is the bookmark that contains the table
‘The collection to apply to the table
‘and a number of rows that makes up the header (these are ignored)
>>
Connection Site Address NMI Start Date
<<codeobject.item.addressObject.Address>> <<codeobject.item.nmi>> <<codeobject.item.CurrentPricing.StartPeriod>>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end