$re = '/(([\S]+),[\S]+)/m';
$str = '2sf,fs,fs, fsgds,ggygyygydf,sfsdfsdf,fssf ,sdfsdffs fsdf,sdffsf
fhfhfhfhfgh ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);