re = /(([\S]+),[\S]+)/m
str = '2sf,fs,fs, fsgds,ggygyygydf,sfsdfsdf,fssf ,sdfsdffs fsdf,sdffsf
fhfhfhfhfgh '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end