const regex = /^(?:[a-z]|\d+)(?:\.\d+)*\.?\s*(?:\([^()]*\)\s*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[a-z]|\\d+)(?:\\.\\d+)*\\.?\\s*(?:\\([^()]*\\)\\s*)?', 'gm')
const str = `c.2 Employed population below international poverty line, by sex and age (%) Age: 15+
b.1 Employed population below international poverty line, by sex and age (%) Age: 15+
a.1 Employed population below international poverty line, by sex and age (%) Age: 15+
1. Employed population below international poverty line, by sex and age (%) Age: 15+
1.2 Employed population below international poverty line, by sex and age (%) Age: 15+
1.1.1 Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.1.C.1) Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.3) Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.4.C.13) Employed population below international poverty line, by sex and age (%) Age: 15+`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);