# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[a-z]|\d+)(?:\.\d+)*\.?\s*(?:\([^()]*\)\s*)?"
test_str = ("c.2 Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"b.1 Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"a.1 Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"1. Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"1.2 Employed population below international poverty line, by sex and age (%) Age: 15+ \n"
"1.1.1 Employed population below international poverty line, by sex and age (%) Age: 15+ \n"
"5.6.2 (S.1.C.1) Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"5.6.2 (S.3) Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"5.6.2 (S.4.C.13) Employed population below international poverty line, by sex and age (%) Age: 15+")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.